Hey SCOM Agent just install your self , please !

11 Feb

Hi,

The last time I notice more and more SCOM 2012 Agent installation fails. Where the SCOM 2007 agent installs fine the SCOM 2012 agent has troubles.

There are plenty of guides on the web but none fixed my problem.

1. Problem:

During the SCOM 2012  agent install (push or manual) the install fails with error 25211 Failed to install performance counters. Error Code: -2147024809

image

2. Analyze

When looking at the deployment log (search for value 3) I noticed that the component failing was the APM module. Secondly it has something to do with registering performance counters. ; – )

3. Solution

When you look on the web you will find as a possible solution KB2554336. Following this article you are rebuilding your performance counters. At my case this rebuild was successful but the agent install still failed. So …

My analyze concluded the setup stopped at the APM module. So why ‘not’ install this module ? I know the server where I am going to install the agent never is going to use this module. How do we do this ? You can do this by supplying the parameter: NOAPM=1

1) On the failed sever open CMD as admin.

2) Copy the agent install files to this server.

3) start the install with :

msiexe /i momagent.msi NOAPM=1

You will notice the installation was successful!!

4. The end

Finally you can use the ops hack in scom db to set this agent from manual to pushed install so it will be patched also.

Happy Scomming,

Michel Kamp

About these ads

8 Responses to “Hey SCOM Agent just install your self , please !”

  1. Vincent February 21, 2013 at 15:00 #

    scom db hack to set an agent from manual to pushed install? Do you have any extra information about this?

  2. Michel Kamp May 10, 2013 at 15:28 #

    What i also detected as solution is to install dotnet 3.5 or higher. In some cases this fixed the problem also

    Michel kamp

    • Daniele Muscetta June 18, 2013 at 16:41 #

      Was this 2012 RTM or SP1? We had a bug in setup in RTM where setup would indeed need .Net 3.5 in order to register those performance counters. SP1′s setup fixes this.

      • michel kamp June 18, 2013 at 20:27 #

        Hi dan,

        It was scom 2012 sp1 ur1

        Michel kamp

      • Daniele Muscetta June 18, 2013 at 22:32 #

        Then we don’t know about it and in which other conditions it might break – I would suggest you open a case with CSS and have it understood and eventually escalated if it turns out to be a bug and not an environmental issue…

      • Michel Kamp June 19, 2013 at 04:44 #

        Thanks, for now the problem is fixed. Next time i will open a case.

        Michel

        Verzonden met mijn Windows Phone ________________________________

  3. Anonymous September 17, 2013 at 11:24 #

    Thanks a lot !! Hours to seek a solution..

    For information our command is wrong, you forgot a “c” ;)
    msiexeC /i momagent.msi NOAPM=1

Trackbacks/Pingbacks

  1. Week of Feburary 11: New from Windows Server/System Center MVPs! - Server and Cloud Partner and Customer Solutions Team Blog - Site Home - TechNet Blogs - February 12, 2013

    [...] Hey SCOM Agent just install your self , please !  [...]

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 26 other followers

%d bloggers like this: